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Safety Instructions 
This chapter contains important safety instructions that must be 
followed when operating GLA and when keeping it in storage. 
Read the following before any operation to insure safety and to 
keep the best condition for GLA. 

Symbols and Guidelines 
 

Symbol 

 CAUTION 

Caution symbol identifies conditions or practices that could result 
in damage to GLA or to other properties. 

 

General 

Guideline 

 CAUTION 

 Do not place any heavy object on GLA. 

 Avoid severe impacts or rough handling that leads to damaging 

GLA. 

 Do not discharge static electricity to GLA. 

 Do not disassemble GLA unless you are qualified as service 

personnel. 
 

Cleaning GLA  Use a soft cloth dampened in a solution of  mild detergent and 
water. Do not spray any liquid into GLA. 

 Do not use chemicals or cleaners containing harsh materials 

such as benzene, toluene, xylene, and acetone. 
 

Operation 

Environment 

 WARNING 

Location: Indoor, no direct sunlight, dust free, almost 
non-conductive pollution (Note below) 

 Relative Humidity: < 80% 

 Altitude: < 2000m 

 Temperature: 0°C to 50°C 
 

Storage 

Environment 

Location: Indoor 

 Relative Humidity: < 80% 

 Temperature: −40°C to 80°C 
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GLA Overview 
This chapter describes GLA series features and appearances in a 
nutshell. Use the Package Contents section to check if  there is any 
missing component. 

 

Main features Series lineup .................................................................. 7 
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Main Features 
 

Series lineup  GLA-1016: 16 channels, 256Kbit/channel 

 GLA-1032: 32 channels, 128Kbit/channel 

 GLA-1132: 32 channels, 1Mbit/channel 
 

Characteristics  100MHz full bandwidth 

 Internal clock range: 100Hz ~ 200MHz 

 External clock range: 0.001Hz ~ 100MHz 

 Rich trigger functionalities: voltage level, count, page, position, 
delay time and clock, edge and level configuration 

 Memory utilization: max. x255 ratio data compression 

 Signal characteristic filtering: Enable function 

 Various signal display mode: waveform, listing, time, frequency, 
and address 

 I2C, RS-232C waveform analyzer 

 Waveform statistics function 

 Compact, lightweight profile 

 PC operation with GUI environment 

 Fast communication: USB 2.0, 1.1 compatible 

 USB bus powered 

 Various file export: operation setting, waveform data, display 
image 



  GLA User Manual 

8 

Package Contents 

Check the contents before using GLA series. Contact your local dealer in case there is a 
missing item. 

 

Carrying case 

contents 

Main 
Unit USB

Cable

Signal
Cable

Signal
Grip

User
Manual

Software
CD-ROM

 
 

GLA-1016  Signal Cable: 8pin*2, 2pin*1, 1pin*1, 250mm 
 Signal Grip: 20pcs 

GLA-1032  Signal Cable: 16pin*1, 8pin*2, 2pin*1, 1pin*1, 250mm 
 Signal Grip: 36pcs 

GLA-1132  Signal Cable: 16pin*1, 8pin*2, 2pin*1, 1pin*1, 250mm 
 Signal Grip: 36pcs 
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Panel Overview 
Start 

Switch
Power
LED

Trigger
LED

Read
LED

Run
LED

Power
Switch

USB
Connector

Input
Connector

 
 

USB Connector For power input (USB bus) and communication between the PC. 
USB 1.1/2.0 compatible. 

 

USB2.0 is strongly recommended for smooth display update. 
Make sure the cable is also compatible with 2.0 high speed (use the 
attached cable). 

 

Power Switch 

Power LED 

Switch On : LED On (red) 

Switch Off : LED Off 
 

 

Trigger LED Turns On when the trigger condition is met. For details, see 
page61 (LED details), page47 (trigger in general). 

 

Read LED Turns On when GLA transmit waveform data to PC. For details, 
see page61. 

 

Run LED Turns On when GLA is waiting for trigger condition. For details, 
see page61. 

 

Start Switch Triggers signal capturing. This is the same functionality as the 

Single Run . For Run/Stop details, see page74. 
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Input Connector 
 

For 
Extension 
Module

 

A0~D7 Signal input terminal. C0 ~ C7, D0 ~ D7 are not applicable to 
GLA-1016. 

 

VDD, IOA/B/C, 

GND 

+3.3V power, IO port, GND terminal for extension module. 

 

Do not use these connectors other than extension module usage 
purpose. 

 

R_O, T_O, S_O Output signals for monitoring data capturing and trigger timing. 
Read output (R_O) indicates waveform data is transferred to PC, 
Trigger output (T_O) indicates trigger condition has occurred, and 
Start output (S_O) indicates GLA started waiting for trigger 
condition. For details, see page61. 

 

CLK External (synchronous) clock signal input, 0.001Hz ~ 100MHz. 
For details, see page41. 

 

GND Ground terminal. 

 

 

We strongly recommend 
connecting both two Ground 
terminals to ensure stable data 
capturing. 
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Display Overview 

Menu bar

Bus/signal 
list

Trigger list

Tooltip

Data capture 
status

Tool bar

Horizontal measurement bar

 

Menu bar 
 

Shortcut Display Description 

Alt + f  
File operation (page29). 

Alt + u  
Bus/Signal configuration (page39). 

Alt + r  
Trigger configuration (page47). 

Alt + s  
Data capturing (page74). 
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Alt + d  
Data operation (page76) and display setup 
(page62). 

Alt + t  
Display setup (page62), Shortcut key setup 
(page100), I2C analysis (page90), and RS-232C 
analysis (page94). 

Alt + w  
Display configuration (page67) and organizing 
multiple files (page37). 

Alt + h  
Help file (page103) and system information 
(page102). 

Tool bar 
 

Toolbar collects icons for major operations, sorted in groups. 

To enable/disable each group, select Tools→Customize… from the menu and go to the 

Toolbar tab. For details, see page63. 

Standard group 
 Page30 

Create a new project file 
 Page31 

Open a project file 

  Page32 
Save the project file 

 Page36 
Print out the display 

 

Trigger group 
 Page40 

Configure sampling rate 
 Page43 

Configure signal/bus 

  Page57 
Setup enable function 

 Page51 
Setup bus trigger properties 

  Page48 
Setup signal trigger properties 

 Page53 
Setup general trigger properties 

  Page42 Enable/disable data compression 
 

Run/Stop group 
 Page74 

Single run 
 Page74 

Continuous run 

  Page75 Stop running 
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Sampling group 
 Page41 

Select sampling memory size 
 

Page41 
Select sampling frequency 

 

Trigger content 

set group 
 Page56 

Set trigger position 
 Page54 

Set trigger page 

 
 Page54 

Set trigger count 
 

Display mode 

group 
 Page65 

Horizontal unit in address 
 Page65 

Horizontal unit in time 

 
 Page65 

Horizontal unit in frequency 

 

 

Windows group 
 Page67 

Waveform display mode 
 Page67 

Listing display mode 
 

Mouse pattern 

group 
 

Normal arrow mode 
 Page88 

Area selection (Enclose) mode 

 
 Page79 

Hand mode 

 Page97 
Show waveform statistics 

 

Zoom group 
 Page88 

Show all waveform data 
 Page89 

Limit the waveform display area 

 
 Page87 

Zoom in to/out of  data 
 

Data group 
 Page78 

Delete data bar 
 Page79 

Move A bar to the center 

 
 Page79 

Move B bar to the center 
 Page79 

Move T bar (trigger) to the 
center 
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 Page78 

Add data bar 
 Page83 

Search data 

 
 Page81 

Go to the previous edge 
 Page81 

Go to the next edge 
 

Show 

time/height 

group 

 Page69 
Show waveform timing 

 Page90 
Analyze I2C waveform 

 Page94 
Analyze RS-232C waveform 

 
Page66 
Change the waveform bar height 

 

Trigger delay 

group 
 Page56 

Set and show the amount of  trigger delay 

Horizontal measurement bar 
 

Displays the horizontal scale and measurement results of  the display. For details, see 
page65. 

Horizontal 

range  

Scale (upper line) shows the data 
acquisition clock frequency. 

Total (lower line) shows the total 
length of  data acquired by GLA, 
followed by the length covered by 
the analysis range bar. For analysis 
range details, see page89. 

 

Position 

 

Display Pos (position) shows the 
timing of  the display center position. 

Trigger Pos (position) shows the 
trigger timing. For details, see page79. 

A/B Position shows user-defined bar 
timings. For details, see page79. 

 

Time/frequency 

difference 

 

Shows the distance between two bars, 
whether trigger or user-defined, in 
time, frequency, or address point. For 
details, see page65. 
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Compression  
Shows the data compression ratio 
when the compression mode is 
enabled. For details, see page42. 

Bus/Signal and Trigger list 
 

 

Signal and bus names are shown in colored codes, 
with matching trigger setting on the right side. 

Bus/signal setup details→page39. 

Trigger setup details→page47. 
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Operation Shortcuts 

This is the collection of  all operations available from the menu, icon, or keyboard shortcut. 
The “Keyboard map” on the Help menu also opens the shortcut list. 

File menu 
 

Description Shortcut Icon Menu 

Close GLA software. Alt+F4 — File→Exit 

Create a new file. Ctrl+N 
 

File→New 

Open a file. Ctrl+O 
 

File→Open 

Close the file. Ctrl+F4 — File→Close 

Save the file. Ctrl+S 
 

File→Save 

Save the file in a different name. — — File→Save As 

Save waveform data and setting info 
into *.txt or *.csv file. 

Ctrl+Shift+E — File→Export 

Save the screen snapshot into *.jpg 
or *.bmp file. 

Ctrl+C — File→Capture Window 

Select the language. — — File→Language 

Prints out the screen snapshot. Ctrl+P 
 

File→Print 

Shows the screen snapshot printout 
preview. 

— — File→Print Preview 

Opens the standard printer setup 
window. 

— — File→Print Setup 

Switch between files. Ctrl+Tab — Window→1, 2, … 

Display multiple files at once. — — Window→Cascade, 

Horizontal, Vertical 

Bus/Signal menu 
 

Description Shortcut Icon Menu 

Open the Sampling setup dialogue 
window. 

— 
 

Bus/Signal→Sampling 

Setup 
Decrease the sampling rate. F2 — — 
Increase the sampling rate. F3 — — 
Open the Channel setup dialogue 
window. 

— 
 

Bus/Signal→Channels 

Setup 
Group signals into bus. Ctrl+G — Bus/Signal→Group into 

Bus 
Ungroup bus into signals. Ctrl+U — Bus/Signal→Ungroup 

from Bus 
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Expand the bus. — — Bus/Signal→Expand 

Collapse the bus. — — Bus/Signal→Collapse 

Automatically adjust the channel row 
width (only in listing mode) 

— — Bus/Signal→Format 

Row→Auto Size 

Move the cursor up. Up — Bus/Signal→Format 

Row→Move Up 

Move the cursor down. Down — Bus/Signal→Format 

Row→Move Down 

Hide the signal/bus. — — Bus/Signal→Format 

Row→Hide 

Show all the signal/bus. — — Bus/Signal→Format 

Row→Show All 

Set the signal/bus color. — — Bus/Signal→Format 

Row→Color 

Rename signal or bus. — — Bus/Signal→Rename 

Trigger menu 
 

Description Shortcut Icon Menu 

Open the Bus trigger setup dialogue 
window. 

— 

 
Trigger→Bus 

Open the Signal trigger setup 
dialogue window. 

— 
 

Trigger→Signal 

Open the General trigger properties 
dialogue window. 

— 
 

Trigger→Properties 

Change signal trigger condition. Space — Trigger→… 

Run/Stop menu 
 

Description Shortcut Icon Menu 

Single run. F5 
 

Run/Stop→Single Run 

Continuous run. F6 
 

Run/Stop→Repetitive 

Run 
Stop running. F7 

 
Run/Stop→Stop 

Data menu 
 

Description Shortcut Icon Menu 

Go to the next data page. PageDown — — 
Go to the previous data page. PageUp — — 
Go to the beginning of  data. Home — — 
Go to the end of  data. End — — 
Move the waveform position right. Right — — 
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Move the waveform position left. Left — — 
Add data bar. Alt+A 

 
Data→Add Bar 

Delete data bar. Alt+B 
 

Data→Delete Bar 

Move T bar to the display center. T, Ctrl+T 
 

Data→GoTo→GoTo 

Trigger 
Move A bar to the display center. A, Ctrl+A 

 
Data→GoTo→GoTo A 

Bar 
Move B bar to the display center. B, Ctrl+B 

 
Data→GoTo→GoTo B 

Bar 
Move any bar (T, A, B, Ds, Dp, user 
defined bar) to the display center. 

— — Data→GoTo→GoTo 

More 
Move to the previous edge. F11 

 
Data→Before 

Move to the next edge. F12 
 

Data→After 

Move the display sideway (use the 
Hand pointer). 

H 
 

Data→Hand 

Select the zoom area (use the 
Enclose pointer) 

E 

 
Data→Enclose 

Use the normal pointer. Esc 
 

Data→Normal 

Search data. Ctrl+F 
 

Data→Find Data Value 

Zoom in. F9 
 

Data→Zoom In 

Zoom out. F8 
 

Data→Zoom Out 

Undo the last zoom. Ctrl+Z 
 

Data→Undo Last Zoom 

Show all data. F10 

 

Data→Show All Data 

Adjust the display range to analysis 
bar. 

— 
 

— 

Select the data analysis range. — — Data→Select Analytic 

Range 
Show waveform analysis result. — 

 
— 

Show waveform data in binary. — — Data→Show As→Binary 

Show waveform data in decimal. — — Data→Show As→
Decimal 

Show waveform data in hexadecimal. — — Data→Show As→
Hexadecimal 

Show waveform in square form. — — Data→Wave Mode→
Square Waveform 

Show waveform in sawtooth form. — — Data→Wave Mode→
Sawtooth Waveform 

Activate data compression. — 
 

— 
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Tools menu 
 

Description Shortcut Icon Menu 

Open the display customize dialogue 
window. 

— — Tools→Customize 

Open the I2C analysis dialogue 
window. 

— 
 

Tools→Analy IIC Wave 

Open the RS-232 analysis dialogue 
window. 

— 
 

Tools→Analy UART 

Wave 
Show the waveform timing. — 

 
Tools→Show time of  

waveform 

Window menu 
 

Description Shortcut Icon Menu 

Open the display customize dialogue 
window. 

— — Tools→Customize 

Show the waveform view. — 
 

Window→Waveform 

Display 
Show the listing view. — 

 
Window→Listing Display 

Show the waveform timing. — 
 

Window→Show time of  

waveform 
Switch between files. Ctrl+Tab — Window→1, 2, … 

Display multiple files at once. — — Window→Cascade, 

Horizontal, Vertical 

Help menu 
 

Description Shortcut Icon Menu 

Open the Help file. F1 — Help→GWInstek Logic 

Analyzer 

Open the keyboard shortcut list. — — Help→Keyboard Map 

Send a bug reporting email. — — Help→Report a Problem 

Show the software version. — — Help→About GWInstek 

Logic Analyzer 
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Installation 
This chapter describes software installation, activation, and 
functionality check. Follow these instructions to properly install 
GLA series. 

 

Software 

installation 

PC requirement ............................................................ 21 

Setup activation ........................................................... 22 

License agreement ....................................................... 22 

User information .......................................................... 23 

Setup type .................................................................... 23 

Custom setup ............................................................... 24 

PC reboot ..................................................................... 24 

Driver installation ........................................................ 24 

Uninstall, repair, modification ...................................... 25 
 

Power Up Power Up ..................................................................... 26 

Demonstration mode ................................................... 27 
 

Functionality 

check 

Hardware connection ................................................... 28 

Signal capturing ........................................................... 28 
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Software Installation 

PC requirement 

The readme.txt file in the CD-ROM also contains this information. 
 

OS 
Windows XP 
Windows 7 
Windows Vista 

 

CPU 
Windows XP: 300MHz minimum 
Windows Vista (Basic): 800MHz 
Windows 7 (32, 64 bit), Vista (all other versions): 1GHz minimum 

 

RAM 
Windows XP: 256MB minimum 
Windows Vista (Basic): 512MB 
Windows 7(32 bit), Vista (all other versions): 1GB  
Windows 7(64 bit): 2GB  

 

Hard disc 
Windows XP: 100MB minimum 
Windows Vista(all versions): 15GB free 
Windows 7(32 bit):16GB 
Windows 7(64 bit):20GB 

 

DirectX 9 (Windows 

7 and Vista only) 

Windows Vista(Basic): 32 MB of  video memory with DirectX 
9-class graphics card. 
Windows Vista (all other versions): 128MB of  video memory.   
Windows (7 & Vista):DirectX 9.0C Redistributable for software 
Developers. It can be downloaded from the Microsoft website: 
http://www.microsoft.com/en-us/download/details.aspx?id=2730 

 

USB 
1 USB host connector, 2.0 compatible  

http://www.microsoft.com/en-us/download/details.aspx?id=2730
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Installation procedure 
 

Setup activation Insert the software CD-ROM into the PC. If  the below Setup 
screen does not appear, double-click the Setup.exe file. 

Click the INSTALL button. 

 
 

License 
agreement 

Read the license term and select accept, click Next. 
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User information Enter your user name and organization. Set the range of  user 
access: All users or the user currently logged in. 

 
 

Setup type Select the setup type. 

Complete setup: All features will be installed. The program 
directory is automatically set. 

Custom setup: Installed features and program directory are set by 
the user. See the next page. 
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Custom setup The custom setup option allows users to select the program 
features and directory. Installed features can be modified later 
(page25). 

 
 

PC reboot Reboot the PC when the installation is completed. 

 
 

Driver 
installation 

By default the driver is installed together with the main program. 
In case the PC requires a separate software driver installation, 
select USB_LA.inf  file in the software package. 
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Uninstall, repair, modification 

This page assumes the GLA software is already installed. 
 

Uninstall Select UnInstall from the PC startup menu, 

 

Or select Remove in the Program Maintenance mode (see below). 
 

Modify/repair Insert the software CD-ROM and activate Setup.exe. The Program 
Maintenance menu appears. 

 

Modify option: Lets the user re-select the installed features. 

Repair option: Checks the program status and fixes any broken 
files. 

Remove option: Uninstalls the software. 
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Power Up 

This section assumes the software is already installed. 
 

Hardware 

connection 

Connect GLA and the PC via the USB cable. Press the GLA 
power switch and make sure the power LED turns On. 

 
 

Software 

activation 
1. Double-click the desktop GLA icon  or activate the 

GLA from the program startup menu. 

 

2. If  the hardware connection error message appears, try the 
following. 
* Reset the GLA USB connection and try again. 
* Make sure GLA and PC are connected by a single USB 
cable (Do not use USB extension cable). 

 

 3. If  there is already a setup file (*.gla) being saved, the software 
asks whether to open it. 
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4. The display appears. 

 
 

Demonstration 
mode 

You can still run the software without the GLA hardware. When 
the Hardware connection failure message appears, click Run Demo 
button. 

 

Most of  the software features are available, except for signal 
capturing. You can even recall the old waveform data to be 
displayed. 
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Functionality Check 
 

Hardware 
connection 

Activate GLA (page26) and connect the signal source to one of  
the input terminals. 

 

Signal capturing Do one of  the following actions to capture the signal. 

 Press the Start button on GLA 

 Click the Run  button on the display 
 Press F5 (shortcut for the single run) 
 Select Single Run from the Run/Stop menu 

 

Make sure the signals appear on the display, at the corresponding 
terminals. 
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File Operation 
 

Open/Close 
Open GLA software ...................................................... 30 

Close GLA software ...................................................... 30 

Create a file .................................................................. 30 

Open a file ................................................................... 31 

Close the file ................................................................ 31 
 

Save 
Save the project file ..................................................... 32 

Save the project file in a different name ....................... 32 

Export the data ............................................................. 32 

Save the display image ................................................. 34 
 

Printout 
Print ............................................................................. 36 

Print Preview ................................................................ 36 

Printer Setup ................................................................ 36 
 

Handling multiple 

files 

Switch between files ..................................................... 37 

Display multiple files ................................................... 37 
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Open/Close 

Open GLA software 
 

Activates GLA software. 

Startup Menu  
 

Desktop icon 

 
 

Note If  there is already a setup file (*.gla) being saved, the software asks 
whether to open it or not. 

 

Close GLA software 
 

Closes GLA software. 

Menu 
 →  

 

Shortcut key Alt+F4 

Create a file 
 

Creates a new project file. 

Menu 
 →  

 

Shortcut key Ctrl+N 
 

Icon 
 

 

File format LaDocx.gla (x stands for integers: 1, 2, 3...) 
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Open a file 
 

Opens an existing setup file. 

Menu 
 →  

 

Shortcut key Ctrl+O 
 

Icon 
 

 

File format *.gla 
 

File properties 

 

The File open dialogue windows shows the file properties of  the 
pointed *.gla file. 

File name, project, author, title, and note can be set at Save As 
dialogue (page32). 

Close the file 
 

Closes the active project file. 

Menu 
 →  

 

Shortcut key Ctrl+F4 
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Save 

Save the project file 
 

Overwrites and saves the active Logic Analyzer project file. If  the file has never been saved 
before, the Save As window appears. 

Menu  →  
 

Shortcut key 
Ctrl+S 

 

Icon  

Save the project file in a different name 
 

Saves the active Logic Analyzer file in a different name, or in a different directory. 

Menu  →  
 

File format 
*.gla 

 

Dialogue window The Save As dialogue window includes File property corner where 
you can fill in the project name, project staff  name, and additional 
note. These information can be viewed when opening the file,  

 

Export the data 
 

Saves waveform data and setup information into *.txt or *.csv format. 

Menu 
 →  
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Shortcut key Ctrl+Shift+E 
 

Dialogue 

window 

 
 

File Type *.txt Plain Text format. 

*.csv Comma-Separated Values format. Each 
waveform data is listed in tables as separate 
entities. 

 

Display 

parameter 

The setup information includes the following: 
 File name, size, date 
 Sampling mode, sampling frequency 
 Ram size, data compression ratio 
 The number of  Bus/channel 
 Trigger level, count, page, Enable setting 
 Bar position 

Yes The file contains system measurement setup 
information as well as waveform data. 

No The file contains only the waveform data. 
 

Data display 

mode 

Vertical Sets the waveform data format into: 
Horizontal direction – channel 
Vertical direction – waveform data 

Horizontal Sets the waveform data format into: 
Horizontal direction – waveform data 
Vertical direction – channel 
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Display data 

range 

Specifies the range of  the saved data. The gray area shows the 
position of  the selected item. 

From:/ To:  Beginning of  data 

 End of  data 

 Trigger bar 

 A bar 

 B bar 

 User defined 

Save the display image 
 

Saves the whole or part of  the PC screen snapshot image, in Jpeg (*.jpg) or Bitmap (*.bmp) 
format. 

Menu 
 →  

 

Shortcut key Ctrl+C 
 

Dialogue 

window 

 
 

Note Note: Adds the entered comment to the captured 
snapshot. 
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 Note color 

 

Clicking the icon opens the chart for selecting 
the note text color. Default: black. 

 

Capture to… File The captured snapshot is saved to an external 
file. 
File format: *.jpg, *.bmp 

Clipboard The captured snapshot is saved to the Windows 
Clipboard, to be pasted into other applications. 

MSPaint The captured snapshot is opened in Microsoft 
Paint, in *.bmp format. 

 

Capture region FullScreen The full screen is captured (same as pressing the 
PrtSc key). 

Select 

Region 

A cropping tool appears, allowing capture of  
selected area. 

 

 

 Selection 

line 

 

Clicking the icon opens the crop tool color chart. 
Checking the opposite of  color radio 

 selects the opposite of  
the specified color, as in the above figure (white 
line). 
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Printout 

Print 
 

Prints out the waveform image. 

Menu 
 →  

 

Shortcut key Ctrl+P 
 

Icon 
 

Print Preview 
 

Shows waveform image printout preview. The file name and the date are also printed out. 

Menu 
 →  

 
File Name Date

 

Printer Setup 
 

Opens the standard printer setup dialog window. 

Menu 
 →  
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Handling Multiple Files 

This section assumes more than one files are already opened. 

Switch between files 
 

Menu Click the target file accessible from the Windows menu. 

 →  
 

Shortcut key Ctrl+Tab 

Display multiple files 
 

Menu 

 →  
 

Cascade format 
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Horizontal 

format 

 
 

Vertical format 
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Bus/Signal Setup 
 

Sampling / 

Compression setup 

Clock source ................................................................ 41 

Sampling RAM size ...................................................... 41 

Compression mode ...................................................... 42 
 

Bus/Signal setup 
Add/Delete ................................................................... 43 

Group/Ungroup ........................................................... 44 

Rename ........................................................................ 45 

Hide/Show signals and buses ...................................... 46 
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Sampling/Compression Setup 

GLA can setup the clock source, sampling frequency, memory size, and data compression. 
 

Menu 
 →  

 

Icon 
 

 

Context menu 

 

Right-click on the Bus/Signal 
list, then select Sampling Setup. 

 

Dialogue 

Window 
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Clock source Internal 

(asynchronous) 

clock 

Toolbar icon  

Frequency is selectable from 18 frequency 
range. 

Range: 100Hz ~ 200MHz. 
 

External 

(synchronous) 

clock 

 

The clock signal needs to be connected to the 
CLK input terminal. 

Range: 0.001Hz ~ 100MHz. 

Rising edge or falling edge is selectable. 

Sampling 

frequency 

To ensure accurate measurement, choose a sampling frequency at 
least four times that of  the target signal. 

 

Sampling RAM 
size 

Toolbar icon 
 

Select the amount of  waveform memory GLA captures in a single 
run. Note that large memory size slows down display update rate. 

 RAM size Channel Compression Enable mode 

 2k bits 16/32 Yes Yes 
16k bits 16/32 Yes Yes 
32k bits 16/32 Yes Yes 

 64k bits 16/32 Yes Yes 
 128k bits 16/32 Yes Yes 

 256k bits 
(GLA-1016/1032) 

16 only No No 

 256k bits 
(GLA-1132) 

32 Yes Yes 

 512k bits 
(GLA-1132 only) 

32 Yes Yes 

 1M bits 
(GLA-1132 only) 

32 Yes Yes 

 2M bits 
(GLA-1132 only) 

16 No No 
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 limitation 

Using large amount of  memory (256k bits for 
GLA-1016/1032, 2M bits for GLA-1132) 
imposes the following restrictions. 
 Only 16 channels, A0 ~ B7, available 
 Compression not available 
 Enable mode not available 

 

Compression 
mode 

Toolbar Icon 
 

When selected, GLA uses a lossless compression technique to 
expand the signal record length. The compression ratio is maximum 
255, automatically adjusted. 

The maximum record length per channel is: 
GLA-1016, 1032: 128kbit x 255 = 32Mbit 
GLA-1132: 1024kbit x 255 = 256Mbit 

The actual compression rate is displayed on the upper-right side of  
the display (In the below case, 1.391). 

 

 

 

Compression 

limitation 

Compression mode imposes the following 
restrictions. 
 For 32 channel model, channel number is 

reduced to 24, A0 ~ C7, regardless of  the 
memory size. 

 Enable mode becomes unavailable. 
 

Enable mode Opens the Enable function setup dialogue window. For details, see 
the Trigger setup chapter, page57. 

 

When 

completed… 

Press Apply/OK/Cancel button to save or cancel the setting. 

Restore Defaults button setting: Internal clock, 100MHz/ 2k RAM 
size/ No compression. 
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Signal/Bus setup 

Add/Delete 
 

Menu 
 →  

 

Icon 
 

 

Context menu 

 

Right-click on the Bus/Signal 
list and select Channel Setup. 

 

Dialogue window 

 

Use the right side bar to scroll up or down. Port C and D are not available in GLA-1016. 
 

Add Bus/Signal 

 

Click the Add Bus/Signal button. A new signal named Newx (x 
stands for 0, 1, 2...) appears on top of  A0. 

 →  
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Delete 

Bus/Signal 

 

 

Select the target signal/bus and click either: 

Delete Bus/Signal – the selected single bus or signal. Or  

Delete All – all buses and signals. 

 

Restore Default 

 

Restores the default status (all channels are active). 

Group/Ungroup 
 

Group signals into bus, or ungroup a bus into signals. 

Menu 
 →  (group) 

 →  (ungroup) 
 

Shortcut keys Ctrl+G (group) 

Ctrl+U (ungroup) 
 

Method1 Open the Channels setup dialogue window, select the grouped 
signals and press Ok. The following example shows that 
ChannelD0 ~ D3 are grouped into D0 bus. 

 Channel Setup dialogue 

 

Result 

 
 

Method2 In the main display, select the range of  signals by pressing the Shift 

key and clicking the signal names. Then choose Bus/Signal → 

Group. A bus named Busx (x stands for 1, 2, 3…) is formed. To 
ungroup the bus, choose Ungroup from Bus menu. 
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 Picking up the signal (D0 ~ D3) 

 

Result 

 

Rename 
 

Method1 Click the target signal in the display. 

 

Click again on the target signal, OR 

Select Rename from the menu, 

 →  OR 

Right-click and select Rename from the context menu. 

 

 Type in the new name and press Enter key to confirm. 
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Method 2 
In the Channels setup dialogue window (page43), Click the target 
signal name, and type in the new name. 

 

Hide/Show signals and buses 
 

This function hides signals and buses from display but do not delete them. Show All 
function can reveal them. For deleting signals and buses, see page43. 

Menu 

 →  →  
 

Context menu Right-click on Bus/Signal list and select Format Row menu. 

 
 

Example Before hiding A1 

 

After hiding A1 
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Trigger Setup 
This chapter describes how to configure the triggering conditions. 

 

Signal triggering 

condition setup 

Set the condition individually ....................................... 48 

Set conditions for multiple channels ........................... 49 

Reset all trigger conditions .......................................... 50 
 

Bus triggering 

condition setup 

Operator (Trigger condition) ........................................ 52 

Reset all trigger conditions .......................................... 52 
 

General triggering 

properties setup 

Trigger level ................................................................. 53 

Trigger Count ............................................................... 54 

Trigger Page ................................................................. 54 

Trigger position ............................................................ 56 

Trigger delay ................................................................ 56 
 

Enable Trigger 

function setup 

Enable Qualifier ........................................................... 58 

Enable Period ............................................................... 59 

Delay Start Point .......................................................... 59 
 

Trigger output 

signal 

Trigger Output Signal ................................................... 61 
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Signal Triggering Condition Setup 
 

Trigger condition Don’t care 

 

GLA captures all data regardless of  its 
condition. 

 High 

 

GLA triggers capturing the signal when the 
level is high. 

 Low 

 

GLA triggers capturing the signal when the 
level is low. 

 Rising edge 

 

GLA triggers capturing the signal when the 
level is changing from low to high. 

 Falling edge 

 

GLA triggers capturing the signal when the 
level is changing from high to low. 

 Either edge 

 

GLA triggers capturing the signal when the 
level is changing from one level to another, low 
to high or high to low. 

 

Set the condition 
individually 

The following method sets the trigger condition for each channel 
individually. 

 Method1 

 

Select the target signal (A1 in this case) and: 

Click the Trigger condition icon repeatedly 

OR 

Press the space bar repeatedly. 
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 Method2 

 →  

Select the target signal (A1 in this case) and click the Trigger list, 
then select the trigger condition from the Trigger menu. 

 

Set conditions 
for multiple 
channels 

This method sets the trigger condition for multiple channels at 
once. 

Open the Trigger dialogue window. 

 Menu 
 →  

 Icon 
 

 Context menu 

 

Right-click on the Trigger list area and 
select Signal. 
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 Dialogue window 

 

Click the the target signal repeatedly and select the appropriate 
trigger condition. 

 

Reset all trigger 
conditions 

Resets all the channel trigger conditions to Don’t care (default) 
state. 

Choose Reset from the Trigger menu 

 →  OR 

Click the Reset button in Signal Trigger Setup dialogue. 
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Bus Triggering Condition Setup 
 

Menu 
 →  

 

Icon 
 

 

Context menu 

 
 

Right-click on the Trigger list for the target bus (Bus1 in this case) 
and select Bus menu. 

 

Dialogue window 
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Operator (Trigger 
condition) 

== GLA triggers capturing data when the 
entered value matches the real data. 

 

Binary 

Sets the value in binary mode: 0, 1, x (don’t 
care). 

Hexadecimal 

Sets the value in Hexadecimal value: 0 ~ F. 

Decimal 

Sets the value in Decimal value: 0 ~ 9. 

 Don’t care GLA triggers capturing data regardless of  
the value. 

 

Reset all trigger 
conditions 

Resets all the bus trigger conditions to Don’t care (default) state. 
Choose Reset from the Trigger menu. 

 →  
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General Triggering Properties Setup 
 

This function sets the triggering properties applicable to all channels and buses. 

Menu 
 →  

 

Icon 
 

 

Context menu 

 

 Right-click on the Trigger list and select Properties menu. 
 

Trigger Properties 

Dialogue window 

 

Port C and Port D are not available for GLA-1016. 
 

Trigger level Set the triggering level for each port, A ~ D. 

 Type Level 

 TTL 1.5V 
 CMOS (5V) 5V 
 CMOS (3.3V) 3.3V 
 ECL −1.3V 
 User Defined −6 ~ 6V 
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Trigger Count Toolbar icon 
 

Sets the number of  times GLA skips triggering condition. Setting 
is available in pull-down (1, 2, 3, 4, 5, 10, 15, 20) or direct entering. 

Example 

 
 

GLA starts capturing data at the first 
triggering condition (default). 

 
 

GLA starts capturing data at the fifth 
triggering condition. 

 
 

You can directly type in any number, up to 
65,535. 

 

Trigger Delay 

dialogue window 

 

Select the Trigger Delay tab in the Trigger Properties dialogue. 
 

Trigger Page Toolbar icon 
 

This function sets the length of  skipped waveform (in data 
memory blocks) after the triggering condition. Setting is available 
in pull-down (1, 2, 3, 4, 5, 10, 15) or direct entering. 

Waveform data in a single page = Sampling RAM size 
(for RAM size setting, see page41) 

Maximum trigger page for different RAM size  

 RAM size GLA-1016 GLA-1032 GLA-1132 

 2Kbit 8192 8192 8192 
 16Kbit 1024 1024 1024 
 32Kbit 512 512 512 
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 64Kbit 256 256 256 
 128Kbit 128 128 128 
 256Kbit 128 128 64 
 512Kbit N/A N/A 32 
 1Mbit N/A N/A 16 
 2Mbit N/A N/A 16 

 

Trigger Page 

Example 
 

GLA captures the data at the first 
triggering condition (default). 

 Trigger

Sampled data
(first page)  

Sampled data = the first memory block 
  

 
 

GLA captures the data at the third 
memory block after triggering condition 
occurs. 

 Trigger

Sampled data
(third page)

First page Second page

 

Sampled data = the third memory block 
  

 

 

You can directly type in any number, up 
to the value shown below. 

 

Trigger page / 

delay  

Trigger page disables Trigger delay/clock function (page56), vice 
versa. 



  GLA User Manual 

56 

 

Trigger position Toolbar icon 
 

Sets the amount of  pre-triggering data that GLA captures, 
selectable from the pull-down menu. 

 

Trigger

Pre-
triggering

Post-
triggering

 

 0% means GLA starts capturing 
data right after the triggering 
condition (no pre-triggering data). 

 50% means half  of  the captured 
data belongs to waveform prior to 
the triggering condition (default). 

 100% means all of  the captured 
data belongs to waveform prior to 
the triggering condition. 

 

Trigger delay Toolbar icon 
 

Delays the data capturing range in reference to the Trigger 
condition. 

 Trigger

Original range

Revised rangeDelay

 

The amount of  delay can be set 
as Time… 

 

Or number of  clocks. 

 

 

Trigger delay / 

Trigger page 

 

Trigger delay disables Trigger page function (page54), vice versa. 



  Trigger Setup 

  57 

Enable Trigger Function Setup 
 

Enable function lets GLA capture data portions only that match specified waveform 
condition – in other words, filters out unnecessary signal. The collected data portions are 
presented as a continuous stream of  signal. 

 
 

 

NOT available 

 When using 128k byte memory for each channel (page41). 
 When using the Compression mode (page42). 

 

Menu Select Sampling Setup from the Bus/Signal menu. Click Enable 
Setup button in the dialogue window. 

 →  → 
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Dialogue window 

 
 

Enable Qualifier Click on the target channel icon and select the condition. 

 Don’t care 

 

The signal level does not matter – always 
captured (default). 

 High 

 

The signal level must be high. 

 Low 

 

The signal level must be low. 

 Example 

The following Enable condition means: 

 

GLA captures signals only when Port A has the following 
condition. 
A0 ~ A7: 01101101 

 

The minimum distance, between each Enable qualified data block, 
is 2 clocks. Otherwise (if  the distance is only one clock) GLA 
continues capturing data and do not delete unnecessary bits. 
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Enable Period This options controls when GLA actually captures data, in 
reference to the Enable Qualifier condition set. 

Check the Enable Delay radio button. 

 

 According to GLA captures signals when input signals 
match the Enable Qualifier. 

 Opposite of GLA captures signals when input signals 
DO NOT match the Enable Qualifier. 

 

Delay Start Point This function fine-tunes the length of  captured waveform, in 
reference to the Enable Qualifier condition. Delay Time configures 
the length of  time (user-defined). Three types of  delay setting, 
Start Edge, End Edge, and Period+Delay are available. 

Example Enable Qualifier 

A0 ~ A3 condition is set as follows. 
Enable Qualifier condition: 0001, Delay Time: 100us 

  

 Start Edge GLA starts recording (capturing) signals at 
the beginning of  Enable Qualifier match, 
for the Delay Time duration. 

100us

A0

A1

A2

A3

Match 
End

Match 
Start

Capture 
End

Capture 
Start  
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 End Edge GLA starts recording (capturing) signals at 
the end of  Enable Qualifier match, for the 
Delay Time duration. 

Match 
End

100us

A0

A1

A2

A3

Match 
Start

Capture 
End

Capture 
Start  

 Period + Delay GLA starts recording (capturing) signals at 
the beginning of  Enable Qualifier match, 
continues after the end of  match for the 
Delay Time duration. 

Match 
End

100us

A0

A1

A2

A3

Match 
Start

Capture 
End

Capture 
Start  

 

When completed… 
When the Enable setting is completed, press OK (confirm) or 
Cancel button. Restore Defaults disables all the qualifier settings. 
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Trigger Output Signal 
 

GLA has three output signals which can be used for monitoring trigger condition. 

Connector 

 

Three signals, S_O, T_O, and R_O, output high level (3.3V) under 
specific conditions. 

 

Signal 

description 

S_O 

(Start Out) 

Outputs high level from when the Start key is 
pressed, or the Run command becomes 
active, until the end of  data capturing. 

 

 

 or F5 

 T_O 

(Trigger Out) 

Outputs high level from when the trigger 
condition is met, until the end of  data 
capturing. 

 R_O 

(Read Out) 

Outputs high level from when the data 
capturing has finished (GLA starts 
transferring data to PC) until the transfer is 
completed. 

 

Diagram 
End

Input

S_O

T_O

R_O

TriggerStart

Data capture

Data transfer  
 

 
GLA cannot capture the next data while R_O is high (data transfer 
not completed yet). 
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Display Setup 
 

Toolbar setup 
Toolbar Setup ............................................................... 63 

Toolbar list ................................................................... 64 
 

Horizontal / Vertical 

scale setup 

Horizontal unit............................................................. 65 

Horizontal ruler ........................................................... 65 

Waveform height .......................................................... 66 
 

Waveform view 

setup 

Signal display ............................................................... 67 

Enable/Disable grid ...................................................... 68 

Square/Sawtooth waveform ......................................... 69 

Waveform timing display .............................................. 69 
 

Color setup 
Background color ......................................................... 71 

Waveform (Foreground) color ...................................... 72 
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Toolbar Setup 
 

Menu Select Customize from the Tools menu. Click the Toolbars tab. 
Click the target toolbar to activate/deactivate it. 

 →  

 

 
 

Context menu Right-click on the blank space in the Toolbar. Click the target 
toolbar to activate/de-activate each group. 
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Toolbar list Standard 
 

 

Trigger 
 

 

Run/Stop 
 

 

Sampling 
 

 

Trigger 

Content Set 
 

 

Display Mode 
 

 

Windows 
 

 

Mouse 

Pattern  

 Zoom 
 

 Data 
 

 Show 

Time/Height  

 
Trigger Delay 
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Horizontal/Vertical Scale Setup 

Horizontal unit 
 

Sets the horizontal unit used in the Scale and Position bar. 

Menu 
 →  

 

Dialogue Window 

 
 

Icon & Display Address mode 

(default) 

 

 

 

Time mode 

 

 

 

 

Frequency mode 

 

 

 

 

Horizontal ruler 
 

Sets the horizontal ruler scale. 

Menu 
 →  →  

 

Dialogue Window 

 
 

Display Regular Scale (default)  
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 Time/Address Scale 

 

Waveform height 
 

Sets the signal/bus displayed height. 

Menu  →  →  
 

Toolbar icon  
 

Dialogue Window 

 
 

Range 18 (default) ~ 100 points 
 

Display 18 points (default) 

 

 30 points 
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Signal Display Setup 

Signal display 
 

Sets the viewing style for signals and buses. 
 Waveform view puts each channel waveform horizontally. 
 Listing view puts each channel vertically, in binary form. 

Menu 

 →  
 

Toolbar icon 
 (Waveform view) 

 (Listing view) 
 

Waveform view 

(default) 

 



  GLA User Manual 

68 

 

Listing view 

 

Enable/Disable grid 
 

Show/hide the vertical gridline in the waveform area. 

Menu 
 →  →  

 

Dialogue Window 

 
 

Display With grid (default) 

 

 Without grid 
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Square/Sawtooth waveform 
 

Selects the waveform edge shape. 

Menu 

→ →  
 

Context menu Right-click on the waveform area and select Wave Mode. 

 
 

Display Square waveform (default) 

 

 Sawtooth waveform 

 

Waveform timing display 
 

Shows/hides timing information inside waveforms. 

Menu 
→  

 

Toolbar icon 
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Display Without timing information (default)  

 

 With timing information 
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Color Setup 

Background color 
 

Sets the waveform background color. 

Menu  →  →  
 

Dialogue Window 

 
 

Change color Press the Background Color bar.  

 

Click the color bar and select color from the color chart. 
 

Contrast with 

foreground 

Check the radio if  you want the foreground (waveform) color to 
be automatically adjusted, following the background color change. 

 
 

Display Black background (default) 
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 White background 

 

Waveform (Foreground) color 
 

Sets the waveform color. 

Menu 
 →  →  

 

Dialogue window 

 
 

Context menu 
Right-click on the Bus/Signal list, Trigger list, or on the waveform, 
select Color menu. The target waveform color can be changed on 
the spot. 

 

Bus/Signal list 

 

 

Waveform 

 

Trigger list 
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Dialogue Window 
Use the single arrow  to change individual waveform color. 

Use the dual arrows  to change all waveform colors at once. 

 
 

Restore default 

settings 

When the changes become complicated, use the Restore button 

 in the Configure dialogue window. 
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Signal Capturing 
This chapter describes how to run/stop capturing signals. 

Single Run 

Captures data for a single period. 
 

Menu 
 →  

 

Toolbar icon 
 

 

Shortcut key F5 
 

Panel operation 

 

Press the Start switch. 

 

Capturing 

succeeded 

Toolbar icon (go back to 
default) 

 

Status bar (left bottom) 

 
 

Capturing failed Toolbar icon 

 

Status bar (left bottom) 

 

Continuous Run 

Continuously captures data. Once the memory becomes full, GLA dumps the waveform 
data on the display, then restart capturing. This process is repeated until the Stop command 
(see next page) is issued. 

 

Menu 
 →  

 

Toolbar icon 
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Shortcut key F6 
 

Capturing 

succeeding 

Status bar (bottom left) keeps updating the amount of  captured 
data in reference to the memory. 

 
 

Capturing failed Status bar (bottom left) stays in the waiting mode. 

 
 

 

Data is not captured while GLA is dumping stored waveform data 
on the display. 

Stop Running 

Stops capturing data. 
 

Menu 
 →  

 

Toolbar icon 
 

 

Shortcut key F7 
 

Capturing 

stopped 

Toolbar icon (go back to 
default) 

 

Status bar (left bottom) 
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Data Operation 
Once GLA captures the data, several operations become available. 
This chapter describes how to search, view, and analyze the 
captured data effectively. 

 

Data bar 

operation 

Activate data bar .......................................................... 77 

Add/Delete data bar ..................................................... 78 

Move data bar .............................................................. 79 
 

Waveform 

position 

Waveform Position ....................................................... 81 

Move the cursor up/down ............................................ 82 
 

Data search Data Search .................................................................. 83 

Data Search Step .......................................................... 83 

Bus search step ............................................................ 85 
 

Zoom Zoom In/Out ................................................................ 87 

Enclose (flexible ratio zoom) ........................................ 88 

Show all data ................................................................ 88 

Manual Display/Analysis Range Setting ....................... 89 
 

I2C bus analysis I2C Bus Analysis ........................................................... 90 

Analysis step ................................................................ 91 
 

RS-232 signal 

analysis 

RS-232C Signal Analysis ............................................... 94 

Analysis step ................................................................ 95 
 

Waveform 

statistics 

Waveform Statistics...................................................... 97 

Statistics setup step ..................................................... 97 
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Data Bar Operation 

Data bar shows the signal position which can be used as a place marker. Using the data bar, 
you can measure relative time, frequency, and points between data. 

Activate data bar 
 

Default state Five data bars are available by default: From left, Ds (start range) A, 
T (trigger), B, and Dp (end range). 

 

 
 

Unit Data bar unit is selectable from address point, time, and frequency. 
Press the toolbar icon to select. For unit selection details, see page65. 

 Address mode 

 

 

Time mode 

 

 

Frequency mode 

 

 
 

Position The positions of  the bars are 
shown on the toolbar. 

 

 

Click the arrow  to select the displayed bar. 

 
 

Relative 

distance 

The distance between each bar is 
also shown on the toolbar.  
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Click the arrow icon  to select the displayed distance. 

 

Add/Delete data bar 
 

Add a bar Menu 
 →  

 Toolbar icon 
 

 Dialogue 

window 

 

You can specify the bar color and position. 
 

Delete a bar Menu 
 →  

 Toolbar icon 
 

 Dialogue 

window 

 

Select the added bar and delete it. 

Note: The default bars (T, A, B, Ds, Dp bar) 
cannot be deleted. 
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Move data bar 
 

Move a bar 

manually 

Toolbar icon 
 

Move the bars manually using the mouse. Point the arrow close to 
the bar until it changes into Hand shape or double arrow. Move the 
bar right or left. 

Note: The T bar position is fixed to the center. 

 
Hand 

 

Double arrow 

 
 

Move a bar to the 

pointed location 

You can move a bar to the exact location that you point in the 
display. 

Right-click the location you want to move the bar, in the display. 
Select Place from the context menu. 

 

 
The target bar (in this case, A bar) moves to the click location. 

 

 For moving bars other than A or B, select the  
option from the context menu. 

Note: The T bar position is fixed. 
 

Move a bar to the 

display center 

Move the bars to the center position of  the display instantly. 

 Menu 
 →  



  GLA User Manual 

80 

 Toolbar icon 
 (T bar) 

 (A bar) 

 (B bar) 

 Shortcut key T (T bar)/ A (A bar)/ B (B bar) 

 Context menu 

Right-click on the display and select Go to. 

 
 

Automatically 

adjust bar 

position to signal 

edge 

When this option is enabled, the bars automatically moves to signal 
edges when there are close. 

Menu 
 →  → 

 

 Check the Auto-Close radio. 
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Waveform Position 

Here we describe how to move the whole waveform display together. 
 

Move the 

previous edge to 

the center 

Search the previous data edge of  the selected signal, move it to the 
display center. 

Menu 
 →  

 Icon 
 

 Shortcut key F11 
 

Move the next 

edge to the 

center 

Search the next data edge of  the selected signal, move it to the 
display center. 

Menu 
 →  

 Icon 
 

 Shortcut key F12 
 

Move the display 

left-right 

manually 

Move the display area left or right manually. The mouse arrow 
changes into Hand style, allowing direct manipulation of  waveform 
positions. 

 Menu 
 →  

 Icon 
 

 Shortcut key H 
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 Context menu Right-click on the display area and select 
Hand. 

 

Move the cursor up/down 
 

Menu 

 →  →  
 

Shortcut key 
Up/Down 

 

Context menu 
Right-click on the Bus/Signal list, select Format Row menu. 
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Data Search 

Search data in the waveform and move the data bars. 
 

Menu 
 →  

 

Icon 
 

 

Shortcut key Ctrl+F 
 

Context menu Right-click on the display and select Find Data Value. 

 
 

Dialogue window 

 
 

Data Search Step 
1. Select the signal. 

 
  

 
2. Select the signal condition. 

 

 
Rising Edge 

 

Falling Edge 

 

Either Edge 
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High 

 

Low 

 

 

  

 
3. Select the search start position. 

 
 Beginning The beginning of  the captured data. 

 Trigger Where the trigger condition occurred. 

 Last Found Where the last data search ended (available 
after at least one data search). 

 A Bar A Bar position. 

 B Bar B Bar position. 

 Other Bar The bar other than A or B. Click  
Toolbar icon for adding a new Bar. For 
more details, see page43. 

  

 
4. Select which bar to place 

when the target data is 

found. 

 
  

 
5. Search the data. Press Next 

or Previous, to search 

forward or backward in the 

waveform. 
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Bus search step 
1. Select the Bus. 

 
  

 
2. Select the Bus condition.  

 Normal Bus 

 

 I2C Bus 

 
  

 
3. Set the Bus value range. 

Enter the value directly 

into Minimum and 

Maximum column. 

 

 

 == Search the Bus condition where its value 
equals the MinPosition value. 

 Not= Search the Bus condition where its value is 
NOT equal to the MinPosition value. 

 In Range Search the Bus condition where its value is 
within the Min/Max Position range. 

 Not In Range Search the Bus condition where its value is 
outside the Min/Max Position range. 

  

 4. Select the search start position. 

 
 Beginning The beginning of  the captured data. 
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 Trigger Where the trigger condition occurred. 

 Last Found Where the last data search ended (available 
after at least one data search). 

 A Bar A Bar position. 

 B Bar B Bar position. 

 Other Bar The bar other than A or B. Click  
Toolbar icon for adding a new Bar. For more 
details, see page78. 

  

 5. Select which bar to place 

when the target data is 

found. 

 
  

 6. Search the data. Click Next  

or Previous, to search 

forward or backward in the 

waveform. 

 

 

  

 7. To see the total number of  

data match, click the 

statistic button. 
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Zoom In/Out 
 

Zoom in Menu 
 →  

 Toolbar icon 
 

 Shortcut key F9 

 Zoom ratio x2 
 

Zoom out Menu 
 →  

 Toolbar icon 
 

 Shortcut key F8 

 Zoom ratio ÷2 
 

Undo the last 

zoom 

Menu 
 →  

 Shortcut key Ctrl+Z 

 Context menu 

Right-click on the signal 
display and select Undo 
Last Zoom. 

 



  GLA User Manual 

88 

 

Enclose (flexible 
ratio zoom) 

Enclose function zooms the selected area into full screen 
horizontal size. When selected, the mouse arrow changes into a 
cropping tool to select the zoom range. 

 Menu 
 →  

 Icon 
 

 Shortcut key E 

 Context menu 

Right-click on the signal 
display and select 
Enclose. 

 
 

Show all data Squeeze and show all the captured data into a single screen. 

 Menu 
 → 

 

 Icon 
 

 Context menu 

Right-click on the signal 
display and select Show 
all Data. 
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Manual Display/Analysis Range Setting 
 

You can set the display range manually, OR 

You can limit the range of  data for I2C (page90), or RS-232 (page94), or Waveform 
statistics (page97) analysis, to delete unnecessary chunk of  data. 

Menu 
 →  

 

Selection step The pointer changes into a hand tool. Grab the Ds (Start point) 
and Dp (End point) bar and move it manually or press the toolbar 
icon to adjust the displayed range automatically. 

 
Start point 

 

End point 

 

Manual setting 

 

Automatic setting 

 

 

Example 
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I2C Bus Analysis 
 

Background This function analyzes the widely popular I2C (Inter-Integrated 
Circuit) bus protocol by extracting the attributes from the captured 
data. 

The bus consists of  two lines, SDA (Serial Data Line) and SCL 
(Serial Clock Line). 

The Data consists of  the following elements. 
  

 
Start condition Indicates the beginning of  communication. 

 ↓  

 
Address 7-bit device address, MSB first. 

 ↓  

 
R/W Read or Write acknowledge bit. 

 ↓  

 
ACK Acknowledgement bit. Confirms reception 

of  the previous byte. 

 ↓  

 
Data 8-bit (one byte) data, MSB first. The 

combination of  ACK and Data is repeated 
for the duration of  the communication. 

 ↓  

 
Stop condition Indicates the end of  communication. 

 

Menu 
 →  

 

Icon 
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Dialogue window 

 
 

Analysis step 
1. Limit the analysis range if  necessary. Select “Select Analytic 

Range” from the Data menu. Limit the analysis range by 

moving Ds  and Dp bar . For details, see 

page89. 

  

 
2. Enter the name of  the new I2C Bus, created upon analysis 

completion.  
  

 
3. Select the SDA (Serial Data Line) and SCL (Serial Clock Line) 

channel. 

 
  

 
4. Select how the I2C Bus value will be displayed: Binary, 

Decimal, or Hexadecimal. 

 
  

 
5. Select the color of  the new I2C analysis Bus. Click each bus 

element’s color bar and select a new color from color chart. 
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 Address/Data 

 

Start bit 

 

Read bit 

 
 Write bit 

 

ACK/NoAck bit 

 

Stop bit 

 
  

 6. Click the I2C Customize button  

and open the Customize window. 

 
  

 
7. Select the Read/Write bit 

activation and polarity. 

Click the Active radio 

button and activate or 

deactivate Read/Write bit. 

 

  

 
8. In active mode, click the 

Read Bit Conditions radio 

button and select the 

polarity. The Write Bit gets 

the opposite polarity. 

 

  

 
9. Select whether the NACK (Non-acknowledge) sign stops I2C 

analysis or not. 
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10. Select the ACK bit polarity. 

NoACK bit gets the 

opposite polarity.  
  

 
11. Enter the Data/Address display name and their bit length. 

 

  

 
12. Address can be shifted one bit left and then ANDed with 

Read/Write bit. 

 
  

 
13. Press OK, Cancel, or 

Default. 

Default contents: 

Read/Write active 

Read Bit High 

Stop analysis upon NACK 

Ack Bit Low 

Address 7 bit/Data 8 bit 

No Address shift 

 

  

 14. Start/Stop I2C analysis.  

A new I2C bus will be created with the result shown as 

configured. 
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RS-232C Signal Analysis 
 

Background This function analyzes the RS-232C signal protocol by extracting 
the attributes from the captured data. 

RS-232C consists of  a single line, including the following elements. 
  

 
Start bit A single bit which indicates the beginning 

of  data packet. 

 ↓  

 
Data 4 to 8 bits data contents. 

 ↓  

 
Parity bit A single bit for detecting error: the number 

of  1s in the data, including parity bit, is 
always odd or even. 

 ↓  

 
Stop bit A single bit which indicates the end of  data 

packet. 

  

 
The other elements include: 

 
Baud Rate The transmission speed: 300 ~ 115200 

bit/s. 

 Direction The data order: MSB or LSB first. 
 

Menu 
 →  

 

Icon 
 

 

Dialogue window 
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Analysis step 
1. Limit the analysis range if  

necessary. Select “Select 

Analytic Range” from the 

Data menu. Move Ds and 

Dp bar and limit the range. 

For details, see page89. 

  

  

 
2. Select the signal channel. 

 
  

 
3. Select the Baud rate. 

 
  

 
4. Select the Data Bit: 4 ~ 8. 

 
  

 
5. Select the Stop Bit width: 

1, 1.5, 2. 

 
  

 
6. Select the Parity: none, 

odd, even. 

 
  

 
7. Select the Data direction: 

MSB first, or LSB first. 

 
  

 
8. Select how the data value is 

displayed in the analysis 

result: binary, decimal, 

hexadecimal, or ASCII 

text. 
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9. Select the color of  the RS-232 analysis result. Click each 

element’s color bar and select a new color from color chart. 

 
  

 
10. If  the reversed polarity data should be used, click the radio. 

 
  

 11. Start/Stop RS-232 analysis.  

The result is displayed as configured. 
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Waveform Statistics 
 

The Statistics function shows the number of  cycles included in the waveform. Cycle period 
and waveform range are configurable. 

Toolbar icon 
 

 

Dialogue 

window 

The statistics window appears at the bottom of  the display. 

 
 

Definition 

Full cycle

Negative 
cycle

Positive 
cycle

 
 

Statistics 
setup step 

1. Limit the analysis 

range if  necessary. 

Select “Select 

Analytic Range” 

from the Data 

menu. Move Ds and 

Dp bar and limit the 

range. For details, 

see page89. 

  

  

 
2. Press the Statistics 

icon. The statistics 

window appears. 
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3. Select the target 

channel if  necessary. 

Press the Channel 

Option button. The 

option window 

opens. Check or 

uncheck the signals. 

 

 
  

 
4. Select the included 

item. Press the Item 

Option button. The 

Item selection 

window appears. 

Check (uncheck) 

items to be included 

(excluded) in the 

statistics window. 

 

 
  

 Probe The probe name for each signal. 

 Integrated periodicities The number of  full cycles included in the 
waveform. 

 Positive periodicities The number of  positive cycles included in 
the waveform. 

 Negative periodicities The number of  negative cycles included in 
the waveform. 

 Eligible integrated 

periodicities 

The number of  full cycles included in the 
waveform, which meet the conditions (see 
below). 

 Eligible positive 

periodicities 

The number of  full cycles included in the 
waveform, which meet the conditions (see 
below). 

 Eligible negative 

periodicities 

The number of  full cycles included in the 
waveform, which meet the conditions (see 
below). 
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 5. Set the cycle period 

condition, if  

necessary. Press the 

Condition Option 

button. The 

conditions window 

opens. Make sure 

the radio is checked. 

 

 

 
 Eligible integrated 

periodicities 

Full cycle period, in ns/us/ms/s. GLA 
counts the number of  full cycle that has 
the same period. 

 Eligible positive 

periodicities 

Positive cycle period, in ns/us/ms/s. 
GLA counts the number of  positive cycle 
that has the same period. 

 Eligible negative 

periodicities 

Negative cycle period, in ns/us/ms/s. 
GLA counts the number of  negative cycle 
that has the same period. 

  

 6. Check the Filter 

radio to filter out 

incomplete data. 

 

  

 7. Press the Refresh 

button. The 

statistics windows 

updates the result. 
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System Setting 

Keyboard Shortcut Setup 
 

Shows the model name and software version. The default setting can be viewed from the 

setup dialogue window, or from Help menu → Keyboard Map, or this user manual 

page16. 

Menu 
 →  →  

 

Dialogue Window 

 
 

Assign a new 

shortcut 

Click inside the New Shortcut key window and press the keys. 

 

Click the Assign button.  

 

The new shortcut is added to the list. 
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Remove a 

shortcut 

Select the target shortcut key inside the Current Keys window. 

 

Click the Remove button.  

The shortcut gets deleted. 

 
 

Restore default 
Click the Reset All button.  

All shortcut keys settings goes back to the default state. 
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System Information 

Version Information 
 

Shows the model name and software version. 

Menu  →  
 

Dialogue Window 

 

Automatic Software Update 
 

GLA checks the software update at power up, then automatically installs the applicable files. 

Menu 
Check On/Off  the Update radio button. 

 →  →  
 

 Internet 

connection 

GLA checks the update information by accessing the server on the 
web. When there is no internet connection, a warning message will 
be generated. 
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Help Information 

Main Help 
 

Opens the main Help file, which includes this manual contents. 

Menu  →  
 

Shortcut key 
F1 

Keyboard Shortcut 
 

Opens the keyboard shortcut file. 

Menu  →  

Tooltip 
 

Shows/hides popup window for showing brief  descriptions when the mouse scrolls over 
toolbar icons and waveforms. 

Menu 
Check On/Off  the Show Tooltip radio button. 

 →  →  
 

Dialogue window 
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Example Toolbar (I2C setup) 

 

 

Waveform 

 

 

The tooltip on the status bar (the bottom left side of  the display) is 
always On. 



  FAQ 

  105 

FAQ
 

The USB is slow, though the PC is USB 2.0 compatible. 

Make sure the cable is compatible with 2.0 high speed (use the 
attached one). 

 

The message “Hardware connection failed” pops up.  

Make sure GLA is powered up and pressing the Retry button. 

Disconnect/reconnect USB cable. 

Do not use extension cable for USB. Make sure GLA and PC are 
connected by a single USB cable. 

 

GLA does not capture signal, or the result is inaccurate.  

Check all signal connections, including the ground terminal, are 
secure. Use both 2 GND cables for stable ground connection. 
Make the distance between GLA and device under test as short as 
possible. 

The sampling rate has to be more than four times that of  the 
signal frequency. 

Regarding trigger: Make sure the trigger threshold matches the 
signal settings. Trigger counter and trigger page should not be too 
large. 

If  the external clock is used, the clock rate might be too low, 
especially if  the internal clock captures signals. 

 

A large portion of the input signal is irrelevant and consumes memory. 

Use the Enable function to set a specific signal condition that 
triggers data capturing. In this way, you will not waste too much 
memory for irrelevant data. See page57 for details. 

 

A large amount of data (more than 32Mbit) is required.  

Use the Data compression feature. It uses lossless compression 
technique so there will be no data loss. See page42 for details. 
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Trigger condition does not occur.  

Make sure trigger threshold matches signal setting. If  the trigger 
condition is too complex, simplify the setting to make it easier for 
data capturing. 

 

Sampling frequency of the input signal is very low. 

Try using the external clock so that the acquiring period is 
extended. Here is the frequency range for internal and external 
clock. 

Internal: 100Hz ~ 200MHz 
External: 0.001Hz ~ 150MHz 

 

If  there is still a problem, please contact your local dealer or GWInstek at 
www.gwinstek.com.tw / marketing@goodwill.com.tw.

http://www.gwinstek.com.tw/
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Specification 
The specifications apply under the following conditions: GLA is powered on for at least 30 
minutes, within +20°C~+30°C. 

 

  GLA-1016 GLA-1032 GLA-1132 
 

Channels  16 32 32 
 

Memory Total/ 

Per Channel 
 

4Mbits/ 

256kbits 

4Mbits/ 

128kbits 

32Mbits/ 

1Mbits 
 

Interface  USB 2.0(1.1) USB 2.0(1.1) USB 2.0(1.1) 
 

Operating 

System 

 Windows XP/ 

Windows 7/ 

Windows Vista 

Windows XP/ 

Windows 7/ 

Windows Vista 

Windows XP/ 

Windows 7/ 

Windows Vista 
 

Bandwidth  100MHz 100MHz 100MHz 
 

Clock Internal 100MHz ~ 

200MHz, 

asynchronous 

100MHz ~ 

200MHz, 

asynchronous 

100MHz ~ 

200MHz, 

asynchronous 

External 0.001Hz ~ 

100MHz, 

synchronous 

0.001Hz ~ 

100MHz, 

synchronous 

0.001Hz ~ 

100MHz, 

synchronous 
 

Trigger Channel 16 32 32 

Condition Edge/Pattern Edge/Pattern Edge/Pattern 

Pre/Post trigger 0% ~ 100% 0% ~ 100% 0% ~ 100% 

Level 1 1 1 

Threshold +6V ~ −6V +6V ~ −6V +6V ~ −6V 

Accuracy ±93mV ±93mV ±93mV 

Count 1 ~ 65535 1 ~ 65535 1 ~ 65535 

Page Maximum 

8191 

Maximum 

8191 

Maximum 

8191 
 

Input Maximum 

Input Voltage 

±30V ±30V ±30V 

 Impedance 500kΩ/10pF 500kΩ/10pF 500kΩ/10pF 
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Specification (cont.) 

The specifications apply under the following conditions: GLA is powered on for at least 30 
minutes, within +20°C~+30°C. 

 

  GLA-1016 GLA-1032 GLA-1132 
 

Enable Channel 16 32 32 

Enable 

Condition 

Don’t care, 

Low, High 

Don’t care, 

Low, High 

Don’t care, 

Low, High 

Enable Delay 1 ~ 65535ms 1 ~ 65535ms 1 ~ 65535ms 
 

Data Skew <1.5ns <1.5ns <1.5ns 

Compression 

Channels 

16 24 24 

Compression 

Ratio 

Maximum 255 Maximum 255 Maximum 255 

 Signal 

Statistics 

Positive/ 

Negative, 

Full cycle 

within length 

condition 

Positive/ 

Negative, 

Full cycle 

within length 

condition 

Positive/ 

Negative, 

Full cycle 

within length 

condition 

 Protocol 

Analyzer 

I2C, RS-232C I2C, RS-232C I2C, RS-232C 

 

Current 

Consumption 

Static Maximum 

200mA 

Maximum 

200mA 

Maximum 

200mA 

Working Maximum 

400mA 

Maximum 

400mA 

Maximum 

400mA 
 

Power 

dissipation 

Static Maximum 1W Maximum 1W Maximum 1W 

Working Maximum 2W Maximum 2W Maximum 2W 
 

Power Interface USB USB USB 

Working 

voltage 

4.5V ~ 5.5V 4.5V ~ 5.5V 4.5V ~ 5.5V 

 

Temperature Operating 0°C ~ 50°C 0°C ~ 50°C 0°C ~ 50°C 

Storage −40°C ~ 80°C −40°C ~ 80°C −40°C ~ 80°C 
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setup .................................................... 77 
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